Shotgun Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
12,957 Posts
Discussion Starter · #1 ·
Shooting clays in the back yard, I have had a reoccuring problem. About 1 in 25 or so shells doesn't fire. I manually cycle the action, catch the shell and look at the primer. Every time it looks like a light primer strike. I have taken the gun apart, dropped out the tirgger assembly and everything, cleaned and lubed it and it still does it. I have no idea what the problem might be. I took the firing pin assembly out last night and took an air compressor to it to try and blow out any goo that might be stuck in there, but I didn't see any come out. Anyone have any ideas?

Im going to shoot a box or two today and if it does it again, I guess I will just call Mossberg. The gun has about 400 round through it.
 

·
Registered
Joined
·
12,957 Posts
Discussion Starter · #5 ·
I would think the ammo too, but a few people were using the same stuff in their their guns. It just looks like light primer strikes, since the spent shells have a much deeper impact on them.

I have been using the Federal bulk pack. Maybe next time I'll try something else just to test the theory.
 

·
Registered
Joined
·
12,957 Posts
Discussion Starter · #6 ·
Next time, get the remington nitro. Same price as the federal at walmart. I've never had any issues with the remington, but have had a few issues with the federal.
 

·
Registered
Joined
·
12,957 Posts
Discussion Starter · #7 ·
Zombie thread I know, but I have dealt with the problem the last few times shooting clays and it has only gotten worse. I tried yesterday and it fired 2 out of 7 times, I just put it up.

I am sending it in to Mossberg today. Anyone have experience with their customer service? Just wondering what their turnaround might be on repairs.
 

·
Registered
Joined
·
12,957 Posts
Discussion Starter · #8 ·
Wow, I just bought mine yesterday. I was so exited about it. Only to find out that once I put 4 shells on it and move the bolt rearwards. The damn thing would not pick a shell. And on top of that. If it did pick a shell, it would jam. I also bought federal self defense 00 buck and federal rifle slugs. I took the gun today to the dealer and they lube it up. Since then, it kindda fix the problem. but it still jams. This sunday Ill be taking mine to the range to shoot the federal ammo. Ill be writing back if anything happens. Has anybody had this problem also ? mine is a mossberg 930.
 

·
Registered
Joined
·
12,957 Posts
Discussion Starter · #9 ·
Wow, I just bought mine yesterday. I was so exited about it. Only to find out that once I put 4 shells on it and move the bolt rearwards. The damn thing would not pick a shell. And on top of that. If it did pick a shell, it would jam. I also bought federal self defense 00 buck and federal rifle slugs. I took the gun today to the dealer and they lube it up. Since then, it kindda fix the problem. but it still jams. This sunday Ill be taking mine to the range to shoot the federal ammo. Ill be writing back if anything happens. Has anybody had this problem also ? mine is a mossberg 930.
What model did you get? Mine is the Turkey one.
 

·
Registered
Joined
·
12,957 Posts
Discussion Starter · #11 ·
Well, today I have change my mind about this Mossberg 930. Its still not picking any shells. Ill try to get someting else cause Im already frustrated with this pos.
 

·
Registered
Joined
·
12,957 Posts
Discussion Starter · #12 ·
Got my shotty back Friday. Tried it out yesterday and it worked flawlessly. No hiccups. Mossberg sent it back saying they replaced a spring and the firing pin and apparently machined a little on one of the parts. Also gave me a barrel plug (the thing you put in the chamber to show its unloaded), new owners manual, lock, and patch holder for cleaning. Nothing awesome, but still nice. The only bad part, is that FedEx ruined the case I sent it in.
 

·
Registered
Joined
·
12,957 Posts
Discussion Starter · #14 ·
I need to send my Mssberg 930SPX in, it has failures to feed regularly and I even put in an enhanced follower to try to fix it.
Hmm, mine would feed, I just got light strikes. I pulled everything apart, trigger group and all, cleaned it really well, and still had issues. Sent it back and it seems to work fine now, haven't really gotten to test much yet. They were fairly quick with the return, but I wasn't in a hurry to get it back, it isn't used for HD or anything like that.

Good luck with sending it back. I just sent it in a decent case and FedEx beat it up pretty bad. That is my only complaint about the whole process. They sent it back with a box around the case, thankfully.
 
1 - 14 of 14 Posts
Top